Config Lab: IPv6 Special Addresses 2

 In 200-301 V1 Ch25: Configure IPv6 Routing, 200-301 V1 Part 7: IPv6, 200-301 V1 Parts, Config Lab, Config Lab CCNA Vol 1 Part 7, Hands-on

This latest config lab takes a backwards approach to configuration. In this case, it starts with a bunch of show commands, and asks you to derive some of the key configuration items on several routers. The theme: IPv6 addressing. By doing this lab, you will need to think hard about the unicast and multicast addresses listed in the output of the show ipv6 interface command.

All about Config Labs

The blog has a series of lab exercises called “Config Labs.” Each lab presents a topology with the relevant initial configuration for each device. The lab also lists new requirements, after which you should create the additional configuration to meet those requirements. You can do the lab on paper, in a text editor, or use software tools like Cisco Packet Tracer or Cisco Modeling Labs.

Once you have created your answer, you can click various tabs at the bottom of this post to see the lab answers, comments about the lab, and other helpful information.

The Lab Exercise

Requirements

This lab begins with a partially-complete configuration. It has some IPv6 configuration, but it is missing some. Your job is as follows:

  • Predict what the current IPv6 configuration of each router is based on the show command output listed in Examples 1 through 6.
  • To test your answer, add your predicted config to the Packet Tracer file supplied with this lab, and then issue the same show commands. Compare the output in this lab post to what you see in Packet Tracer.
  • The answers below show the config that you would need to add so that the show commands will produce the output shown.

For this lab, you can make these assumptions:

  • All router interfaces shown in the lab are up and working.
  • IPv6 routing (ipv6 unicast-routing) is enabled
  • The figure shows the planned IPv6 subnets, with plans to use OSPF process 10 on all routers and area 0 throughout the design. However, some of those features may not as of yet be configured.

Figure 1 shows the topology. Examples 1 through 6 then list the output of the show ipv6 interface command on the routers for various interfaces. Finally, Examples 7, 8, and 9 show some of the initial configuration on the three routers.

Figure 1: Three Router Topology

 

R1# show ipv6 interface GigabitEthernet 0/1
GigabitEthernet0/1 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::F816:3EFF:FE43:122C 
  No Virtual link-local address(es):
  No global unicast address is configured
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::5
    FF02::6
    FF02::1:FF43:122C
  MTU is 1500 bytes
! lines omitted for brevity

Example 1: R1 Gi0/1 interface

 

R1# show ipv6 interface GigabitEthernet 0/2.1
GigabitEthernet0/2.1 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::F816:3EFF:FE48:B29 
  No Virtual link-local address(es):
  No global unicast address is configured
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::5
    FF02::6
    FF02::1:FF48:B29
  MTU is 1500 bytes
! lines omitted for brevity

R1# show ipv6 interface GigabitEthernet 0/2.2
GigabitEthernet0/2.2 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::F816:3EFF:FE48:B29 
  No Virtual link-local address(es):
  No global unicast address is configured
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::5
    FF02::6
    FF02::1:FF48:B29
  MTU is 1500 bytes
! lines omitted for brevity

Example 2: R1 Gi0/2 subinterfaces

 

R2# show ipv6 interface GigabitEthernet 0/1
GigabitEthernet0/1 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::F816:3EFF:FEDA:CC6 
  No Virtual link-local address(es):
  No global unicast address is configured
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::5
    FF02::6
    FF02::1:FFDA:CC6
  MTU is 1500 bytes
! lines omitted for brevity

Example 3: R2 Gi0/1 Interfaces

 

R2# show ipv6 interface GigabitEthernet 0/2
GigabitEthernet0/2 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::F816:3EFF:FE45:4B7F 
  No Virtual link-local address(es):
  No global unicast address is configured
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::5
    FF02::6
    FF02::1:FF45:4B7F
  MTU is 1500 bytes
! Lines omitted for brevity

Example 4: R2 Gi0/2 Interface

 

R3# show ipv6 interface GigabitEthernet 0/1
GigabitEthernet0/1 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::F816:3EFF:FE0A:4A64 
  No Virtual link-local address(es):
  No global unicast address is configured
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::5
    FF02::6
    FF02::1:FF0A:4A64
  MTU is 1500 bytes
! Lines omitted for brevity

Example 5: R3 Gi0/1 Interface

 

R3# show ipv6 interface GigabitEthernet 0/2
GigabitEthernet0/2 is up, line protocol is up
  IPv6 is enabled, link-local address is FE80::F816:3EFF:FE23:D9E 
  No Virtual link-local address(es):
  No global unicast address is configured
  Joined group address(es):
    FF02::1
    FF02::2
    FF02::5
    FF02::6
    FF02::1:FF23:D9E
  MTU is 1500 bytes
! Lines omitted for brevity

Example 6: R3 Gi0/2 Interface

 

Initial Configuration

Examples 7, 8, and 9 show the beginning configuration state of R1, R2, and R3.

hostname R1
!
ipv6 unicast-routing
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255

Example 7: R1 Config

 

hostname R2
!
ipv6 unicast-routing
!
interface Loopback0
 ip address 2.2.2.2 255.255.255.255

Example 8: R2 Config

 

hostname R3
!
ipv6 unicast-routing
!
interface Loopback0
 ip address 3.3.3.3 255.255.255.255

Example 9: R3 Config

Lab Answers Below: Spoiler Alert

Lab Answers: Configuration (Click Tab to Reveal)

Answers

Figure 1: Three Router Topology

 

The IPv6 Configuration that Existed at the Beginning of the Lab

Examples 1, 2, and 3 show the additional IPv6 configuration that existed in the configuration at the beginning of this lab.

interface GigabitEthernet0/1
 ipv6 enable
 ipv6 ospf 10 area 0
 no shutdown
!
interface GigabitEthernet0/2
 no shutdown
!
interface GigabitEthernet0/2.1
 encapsulation dot1q 10
 ipv6 enable
 ipv6 ospf 10 area 0
!
interface GigabitEthernet0/2.2
 encapsulation dot1q 20
 ipv6 enable
 ipv6 ospf 10 area 0

Example 1: R1 Config

 

interface GigabitEthernet0/1
 ipv6 enable
 ipv6 ospf 10 area 0
 no shutdown
!
interface GigabitEthernet0/2
 ipv6 enable
 ipv6 ospf 10 area 0
 no shutdown

Example 2: R2 Config

 

interface GigabitEthernet0/1
 ipv6 enable
 ipv6 ospf 10 area 0
 no shutdown
!
interface GigabitEthernet0/2
 ipv6 enable
 ipv6 ospf 10 area 0
 no shutdown

Example 3: R3 Config

Commentary, Issues, and Verification Tips (Click Tabs to Reveal)

This lab takes a much different approach than the other Config Lab posts. How did you do?

The show ipv6 interface commands on routers R1, R2, and R3 showed you some addresses. However, it did not list some addresses you may be used to seeing: global unicast addresses. In this case, the initial configurations did not include any ipv6 address interface subcommands to configure any global unicast addresses. Basically, the lab state for this lab post is that IPv6 is enabled, with OSPF enabled as well, but without the global unicast addresses configured.

So, what configuration appears to have already been configured?

First, each router interface (or in the case of router R1, a couple of subinterfaces as well) had an ipv6 enable command configured. How can you determine this? Well, the output on each interface states “no global unicast address is configured”, which means that there is no ipv6 address command configured on the interface. At the same time, IPv6 is clearly enabled on the interface per many parts of the command output.

The ipv6 enable command:

  • Enables IPv6 on the interface
  • Causes the router to calculate its link local (unicast) address on that interface
  • Causes the router to calculate the solicited node multicast address associated with that link local address

Because of an interface’s ipv6 enable command, you should see each interface with a link local address (begins with FE80). You should also see a matching solicited node multicast address, which begins FF02::1:FF, followed by the same last 6 hex digits as the link local address.

That ipv6 enable command also enables the use of two multicast addresses, again found on each interface/subinterface in examples 2 through 7 in the lab post:

  • FF02::1 – All nodes
  • FF02::2 – All routers

Note that if the configuration had happened to have included an ipv6 address command to configure a global unicast address, that command would also have triggered the addition of these two multicast addresses. However, the output states “no global unicast address is configured”, which tells us that the ipv6 address command was not configured.

Finally, each interface also has OSPFv3 enabled, although the output does not tell you enough details about the specifics of the commands used by OSPF. In this case, the interface subcommand happened to be ipv6 ospf 10 area 0.  As a result, each interface also showed the router listening for two additional IPv6 multicast addresses to support OSPF:

  • FF02::5 – All OSPF routers
  • FF02::6 – All OSPF DRs and BDRs

Known Issues in this Lab

This section of each Config Lab Answers post hopes to help with those issues by listing any known issues with Packet Tracer related to this lab. In this case, the issues are:

 

# Summary Detail
1 Packet Tracer performs EUI-64 incorrectly when the 7th bit of the MAC is a 1. When performing the 7th-bit bit-flip, PT sets the 7th bit to 1, rather than flipping or inverting the bit. So, if the 7th bit of the MAC address is a 1, PT leaves the bit as a 1. A real Cisco router would flip the bit to 0.
2 OSPFv3, when configured, does not display the IPv6 FF02::6 multicast address to appear in show commands. The show ipv6 interface command should display both OSPFv3 well-known multicast addresses: FF02::5 and FF02::6. PT displays only FF02::5.

 

Why Would Cisco Packet Tracer Have Issues?

(Note: The below text is the same in every Config Lab.)

Cisco Packet Tracer (CPT) simulates Cisco routers and switches. However, CPT does not run the same software that runs in real Cisco routers and switches. Instead, developers wrote CPT to predict the output a real router or switch would display given the same topology and configuration – but without performing all the same tasks, an actual device has to do. On a positive note, CPT requires far less CPU and RAM than a lab full of devices so that you can run CPT on your computer as an app. In addition, simulators like CPT help you learn about the Cisco router/switch user interface – the Command Line Interface (CLI) – without having to own real devices.

CPT can have issues compared to real devices because CPT does not run the same software as Cisco devices. CPT does not support all commands or parameters of a command. CPT may supply output from a command that differs in some ways from what an actual device would give. Those differences can be a problem for anyone learning networking technology because you may not have experience with that technology on real gear – so you may not notice the differences. So this section lists differences and issues that we have seen when using CPT to do this lab.

Beyond comparing your answers to this lab’s Answers post, you can test in Cisco Packet Tracer (CPT) or Cisco Modeling Labs (CML). In fact, you can and should explore the lab once configured. For this lab, once you have completed the configuration, try these verification steps. 

  1. When configuring, add just one IPv6 interface subcommand and then issue a show ipv6 interface command and look for the notes about unicast and multicast addresses.
  2. Continue to configure one interface at a time, and then repeat the show ipv6 interface command, until you get a sense for which configuration commands cause the various unicast and multicast addresses to appear in the show command output. 

More Labs with Related Content!

Answer Options - Click Tabs to Reveal

You can learn a lot and strengthen real learning of the topics by creating the configuration – even without a router or switch CLI. In fact, these labs were originally built to be used solely as a paper exercise!

To answer, just think about the lab. Refer to your primary learning material for CCNA, your notes, and create the configuration on paper or in a text editor. Then check your answer versus the answer post, which is linked at the bottom of the lab, just above the comments section.

You can also implement the lab using the Cisco Packet Tracer network simulator. With this option, you use Cisco’s free Packet Tracer simulator. You open a file that begins with the initial configuration already loaded. Then you implement your configuration and test to determine if it met the requirements of the lab.

(Use this link for more information about Cisco Packet Tracer.)

Use this workflow to do the labs in Cisco Packet Tracer:

  1. Download the .pkt file linked below.
  2. Open the .pkt file, creating a working lab with the same topology and interfaces as the lab exercise.
  3. Add your planned configuration to the lab.
  4. Test the configuration using some of the suggestions below.

Download this lab’s Packet Tracer File

You can also implement the lab using Cisco Modeling Labs – Personal (CML-P). CML-P (or simply CML) replaced Cisco Virtual Internet Routing Lab (VIRL) software in 2020, in effect serving as VIRL Version 2.

If you prefer to use CML, use a similar workflow as you would use if using Cisco Packet Tracer, as follows:

  1. Download the CML file (filetype .yaml) linked below.
  2. Import the lab’s CML file into CML and then start the lab.
  3. Compare the lab topology and interface IDs to this lab, as they may differ (more detail below).
  4. Add your planned configuration to the lab.
  5. Test the configuration using some of the suggestions below.

Download this lab’s CML file!

 

Network Device Info:

The CML topology matches the lab topology.

Config Lab: IPv6 Special Addresses 1
Config Lab: Standard Numbered ACL 1
Subscribe
Notify of
guest

19 Comments
Oldest
Newest Most Voted
Inline Feedbacks
View all comments
Carlos Maurício Borgonovi Garcia Tejeda

Hi,

Shouldn’t it be necessary to add the configuration of the OSPFv3 router process with the command
ipv6 router ospf 10?

Thank you.

certskills

Hey Carlos,
The router will add the **ipv6 router ospf 10** command in response to the first of those interface subcommands. But you could also configure it for yourself – just not required.
wendell

Christian

Hi Mr Wendell,

I did all configurations for training by myself and I enabled OSPFv3. Everything works but when I check the multicast addresses I don’t see FF02::6 (all DR routers). How come?

Thanks in advance for your reply

Christian

James Townsend

Hey Wendel,

Would the G0/2 sub-interfaces off R1 each require a ‘mac-address’ command with a different address for each?

I believe end-user list the link-local address of the router interface as their gateway address, and I could see this being problematic if the link-local address is the same on both vlan’s which it currently appears to be in the initial config.

I believe the mac-address commands would influence the EUI-64 process used when generating the link-local addresses for each sub-interface and mitigate the issue

James Townsend

Thanks Wendel much appreciated!

GJM

I’m not sure if I’m following this lab correctly. The objectives state to just predict what the config might be on the 3 routers by using show commands. It doesn’t say anywhere to do any configuration. Also when using show ipv6 interfaces, nothing is output on any of the 3 routers. Am I missing something here?

John rambo

Hello Odom,

There seems to be a glitch in the matrix!

Your lab commentary doesn’t seem to match the actual lab!

Thank you

John rambo

Also you mentioned in ‘Lab Answers Below: Spoiler Alert’ ‘The ipv6 enable command……..Causes the router to calculate the solicited node multicast address associated with that link local address’

I thought that the solicited-node multicast address is a multicast group that corresponds to an IPv6 unicast or anycast address?

Thank you

GJM

Hi I just ran through this lab and did the configuration to verify, and I did NOT include ipv6 enable on any of the interfaces and it still generates the link local and joins the multicast address groups. I also then entered the ipv6 enable on the interfaces after the fact and nothing changed or showed differently. So in real life that command is needed but it is implied on Packet Tracer by just programming ipv6 addresses on the interfaces?

Wendell

GJM,
Interesting. I just tried it and get different results. Here’s what I did; what did you do differently?
1) Download and open the supplied .pkt file for the lab.
2) Entered R1 CLI
3) Issued “show run” to confirm there are no “ipv6 enable” commands listed on any interfaces.
4) issued “show ipv6 interface g0/1” to look for details… and get one blank line of output.
5) Get into config mode and configure “ipv6 enable” under g0/1.
6) Back in EXEC mode, I again issue “show ipv6 int g0/1”, and see the addresses appear.

Thanks,
Wendell

Tewa

Hello Wendell,

Does the use of ipv6 unicast-routing not also have the same effect as ipv6 enable? That is, will the use of ipv6 unicast-routing without adding ipv6 address also enable all the items listed in the lab commentary?

Alexis Ledesma

any reason why i don’t get any output when entering the show ivp6 interface command ?

Contact Us

We're not around right now. But you can send us an email and we'll get back to you, asap.

19
0
Would love your thoughts, please comment.x
()
x